Connection errors on phone calls
NokiaUsers.net is the premier Nokia Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 27 of 27
  1. #1
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Connection errors on phone calls

    My phone has been having some serious and very frequent connection errors on phone calls. The line just gets disconnected in the middle of a call. On both incoming and outgoing calls
    . I just read in another post here, that someone had this too and that they were advised to switch from UMTS to GSM network. What I would like to know, is how many people are actually suffering from this problem? And if the mentioned solution really does help?? Or are there other ways of solving this? (besides not using the N95)

  2. Remove Advertisements
    NokiaUsers.net
    Advertisements
     

  3. #2
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, so I've talked to my provider and here's what they say. Does this sound familiar to anyone?

    question:
    When the network mode on my phone set to only UMTS, my calls are sometime disconnected. Can this maybe be related to the UMTS coverage?

    reply:
    You have to update your cellphone software. It is a problem called Hand over.

    question:
    Ok, there's also an option on this setting called "dual mode". Would this maybe help in automatically switching between UMTS and GSM depending on coverage?

    reply:
    Yes, but the problem will still remain. Please contact your cellphone manifacturer.

  4. #3
    Nokia Guru
    Join Date
    Apr 2007
    Location
    Staines, UK
    Posts
    1,064
    Thanks
    2
    Thanked 46 Times in 40 Posts
    What rubbish!

    Basically their network coverage is rubbish for 3G, and they're blaming the mobile makers.

    Which network & Country?

  5. #4
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm on the Telenor network in Sweden. But it is really rubbish? I would actually like to believe both points of view. I mean, the lack in coverage does make sense, but the hand-over issue as well. Cause Google does come up with results on the subject, and Google doesn't lie ;-)

  6. #5
    Nokia Guru
    Join Date
    Apr 2007
    Location
    Staines, UK
    Posts
    1,064
    Thanks
    2
    Thanked 46 Times in 40 Posts
    Bad quality handover is almost always caused by poor signal.

    If using UMTS/3G only, switch to dual mode. It will help as it should switch between UMTS and GSM whenever there is poor signal.

  7. #6
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, I'm gonna go trial-and-error on this and just try the dual setting. But let's say that I do that, would the disconnecting problem be gone then? I mean, maybe the line will get disconnected first and then the switch to GSM is being made. Or should the phone be so advanced, that it hangs on to the call while making the switch and without me even knowing it :-)

  8. #7
    Nokia Guru
    Join Date
    Apr 2007
    Location
    Staines, UK
    Posts
    1,064
    Thanks
    2
    Thanked 46 Times in 40 Posts
    Quote Originally Posted by rogiervdwel View Post
    Or should the phone be so advanced, that it hangs on to the call while making the switch and without me even knowing it :-)
    Yup, that's how it works.

    You still havent said country and network, as that might be a factor too!

  9. #8
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh sorry. I realized that I forgot so I edited on of the above posts just after it was posted. So you probably missed it. My bad.

    Anyway, it's the Telenor network in Sweden.

  10. #9
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, so one of my options isn't working out that good. I tried to set my network mode to GSM. You'd think that this would solve the disconnecting problem as well, being that there are no more switches bewtee UMTS and GSM. But guess what? During a recent phone call, I got disconnected again after a few minutes. #%%&!!!@@ This is starting to really really piss me off. I have the setting to dual mode now, but if I get one more connection error, the phone is going straight back to Nokia.

  11. #10
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Angry Bye bye N95

    And so I guess this might be it. If I can't call with a phone, it's becoming quite useless. I just set the network to dual and a few minutes after I received a call. After 10 minutes.......yep, disconnected again.
    Tomorrow morning I'll visit the Nokia Service Center in this area and ask for either a replacement or I'm just gonna let Nokia have it back. I've had the phone for a week and a half now, and having my calls disconnected more and more over the last few days is not my idea of a good phone. I realize however that this is not a common problem, so I don't know what Nokia plans to do about my situation but I'll just wait and see.

  12. #11
    Nokia Guru
    Join Date
    Apr 2007
    Location
    Staines, UK
    Posts
    1,064
    Thanks
    2
    Thanked 46 Times in 40 Posts
    Have you previously used this network in the same areas without issues?

    Have you checked your network signal strength map to check your area is good?

  13. #12
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just got this phone a week and a half ago. Before then, I had my old phone with the same simcard and the same network. And I wasn't being disconnected like now. Not at all actually. And also, I put the card in my old phone just now. And I've been talking for at least an hour now without any problems. With the Nokia I got disconnected every 30 minutes or so.

  14. #13
    Nokia Guru
    Join Date
    Apr 2007
    Location
    Staines, UK
    Posts
    1,064
    Thanks
    2
    Thanked 46 Times in 40 Posts
    Sounds like a phone fault - providing your old sim card was a 3G one.

    Return it for a replacement in store.

  15. #14
    Nokia Guru Tommie's Avatar
    Join Date
    Apr 2007
    Location
    Sweden
    Posts
    4,908
    Thanks
    4,750
    Thanked 1,761 Times in 1,091 Posts
    Quote Originally Posted by rogiervdwel View Post
    Tomorrow morning I'll visit the Nokia Service Center in this area and ask for either a replacement or I'm just gonna let Nokia have it back. I've had the phone for a week and a half now, and having my calls disconnected more and more over the last few days is not my idea of a good
    Strange?? But yes cheek your problem with service center it sounds problem with Telenor? something haves got really wrong . I hope they fix your problem tomorrow. Good luck

    Cheers

  16. #15
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I think I've either run into some bad luck and have few faulty N95. Or it's just the combination of the N95 with Telenor. Cause Telenor works just fine in the old phone. Anyway, I'm gonna explain things at the service center and maybe they have an idea or 2.

    And thanks.

  17. #16
    Nokia Guru Tommie's Avatar
    Join Date
    Apr 2007
    Location
    Sweden
    Posts
    4,908
    Thanks
    4,750
    Thanked 1,761 Times in 1,091 Posts
    I hope and think they fix it.
    cheers

  18. #17
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I hope so too!!! It's simply an awesome phone. But like any other phone, it should be able to call :-) Maybe they can replace it, or fix it, I don't know and I don't care. Just make sure that I'm able to call again with an N95!

  19. #18
    Nokia Guru Tommie's Avatar
    Join Date
    Apr 2007
    Location
    Sweden
    Posts
    4,908
    Thanks
    4,750
    Thanked 1,761 Times in 1,091 Posts
    I totally agree ofcorse you shud fix the mainthing (to call) sry it allmost sounds sick (You want to call on your phone??hmm if is only a phone) It be fun hear what they say
    when u say u want make a call with your phone..) I belive they fix it
    Cheers

  20. #19
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just came back from the NSC. The lady said they might upgrade the firmware. "No need for that, already updated mine last week" :-) So that rules out it being solved by the latest firmware. Now they're gonna take it apart to have a look at the receiver and some other stuff. While they're at it they're also gonna try and do something about the slider. And on top of that I hope they might be able to fix the multimedia button which sometimes doesn't do anything (but that might be software related though)

    Anyway, if they don't have to send it back to Nokia, I'll have it back before the weekend. If the phone does go back to Nokia, it'll take about 2 weeks. But my guess is, with the above problems, it'll be the latter. As long as they fix it, one way or another. So now, I'll surf back to the Qtek 8500 user forum, since that's my crappy old backup phone for the time being:-)

  21. #20
    Nokia Guru Tommie's Avatar
    Join Date
    Apr 2007
    Location
    Sweden
    Posts
    4,908
    Thanks
    4,750
    Thanked 1,761 Times in 1,091 Posts
    I think better they fix all your problem now when they get the phone.
    Hoppefylly u get it back soon

  22. #21
    Newbie
    Join Date
    May 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Red face "connection error"

    Hi guys,

    I just wanted to say that I too have this problem. My calls dont last more than a few minutes before i get the "connection error" tone and it dosconnects my call. I agree this is very annoying. I live in the UK and I'm with T-mobile. I have had the phone for a week and it happens on every call I make. At first I thought it was the connection between my bluetooth headset but I tried the phone on its own and the same problem occured.

    My friend works for T-mobile and will do an exchange for me tomorrow. If the same problem occurs with the next N95 I will probably go for another phone... perhaps N93i???

    Will let you know how the new one gets on

  23. #22
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well now, it seems that I'm not the only one. It makes me both happy and sad actually. Happy because this would probably mean that it's not the first time Nokia gets a returned N95 with this problem so they most likely will replace it with a phone of the new batch. But sad because it makes you wonder: what if? What if my new one will also have the issue.......
    If I had to choose another phone I would go for the N76. But I guess that one could and would have similar issues, being a new phone and all.
    Last edited by rogiervdwel; 05-11-2007 at 10:32 AM.

  24. #23
    Newbie
    Join Date
    May 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi ther has any1 had problems with u can hear whoever called u but they cant hear you, and also while goin thro phne it keeps saying memory full close some applications so annoying!

  25. #24
    Newbie
    Join Date
    May 2007
    Location
    Sweden
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Personally I haven't had this problem, but these people on allaboutsymbian.com have. Maybe it's helpful

  26. #25
    Newbie
    Join Date
    Aug 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    disconnections

    Hi,

    I live in Sydney and I'm on my second N95 now. I had the first one for about a month till I gave up and got the 3 provider to swap it for a new one. I had random restarts, multimedia button failure, disconnections of calls and in the end the phone just died. Now on my second phone that I had for about 2-3 weeks, I start getting disconnections of calls and yesterday the phone restarted during a call. Nokia are sending out phones way to early before they even get them tested. ( And the sad bit too is that calling your 3 provider for support, cost me time and money and their support most of the time are useless.
    Good phone but not stable enough, come on Nokia, you can do better )

    Regards,
    Pelle

  27. #26
    Newbie
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi I have had my N95 for approximately 5 weeks and I try not to use it now because 95% of my calls disconnect.. Either incoming or outgoing.. "CONNECTION ERROR" I am not technically savvy so the technical ideas that people post on here is like another language to me - so I will be going back to the Optus store I bought my Nokia from and seeing what they do and say? It is a very very frustrating error that seems to be a little more common than we think?

  28. #27
    Newbie
    Join Date
    Jul 2008
    Location
    Australia
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Disconnected Calls - Won't let me call out

    Hello,
    I have had my new Nokia N95 8GB for only a week or so now and quite often, right in the middle of a call it just cuts out ....
    I have also had quite a few instances when I select someone from my contacts it simply won't connect when I try to ring them. After a few attempts it usually connects?
    I am in the Newcastle area in Australia and had no troubles with my backup phone Nokia 6300 (but it is not 3G of course)
    rogiervdwel did you have any success with yours? Or did anyone that has had this problem get an explanation?

    Might have to head back to Optus store also!

Similar Threads

  1. SIP Outgoing calls getting 'Connection Error'
    By Dellinja in forum Carrier and Connectivity
    Replies: 9
    Last Post: 05-12-2010, 09:27 AM
  2. Replies: 4
    Last Post: 03-27-2008, 05:46 PM
  3. 2 phone errors
    By cjrob in forum Its Broke!
    Replies: 2
    Last Post: 12-17-2007, 08:58 PM
  4. Connection Issue? on Phone calls - help?
    By ddot in forum Its Broke!
    Replies: 9
    Last Post: 10-11-2007, 11:57 AM
  5. Phone Restarting Itself During Calls
    By michie79 in forum Its Broke!
    Replies: 15
    Last Post: 05-26-2007, 04:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts