Nokia N95: Dead camera? [with pics!]
NokiaUsers.net is the premier Nokia Forum on the internet. Registered Users do not see the above ads.
Results 1 to 10 of 10
  1. #1
    raz
    raz is offline
    Newbie
    Join Date
    Apr 2007
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Nokia N95: Dead camera? [with pics!]

    It appears that some N95 units have a rather annoying "bug".
    Simply put, the main camera suddenly, and it seems permanently, stops working.
    The secondary camera, however, remains unaffected.

    I've taken and included some images to demonstrate the issue.

    The problem persists with/without microSD/SIM.

    All kinds of resets (*#7370#, *#7780#, 3 + green button + *) were tried.
    Re-updating the phone (RM-159_11.0.026) by changing the product code
    was also attempted, but the issue remains.

    It seems that others accross the internet have also experienced the same problem.

    Any (constructive) suggestions?

    Working secondary camera:


    Dead main camera:



  2. Remove Advertisements
    NokiaUsers.net
    Advertisements
     

  3. #2

    Join Date
    May 2007
    Posts
    69
    Thanks
    0
    Thanked 10 Times in 6 Posts
    I would take it back and demand they give me a new phone. After all the money spent on this phone thats what you get? Take it right back and demand a new one.

  4. #3
    Nokia Oracle pseudofinn's Avatar
    Join Date
    Feb 2007
    Location
    Michigan, USA
    Posts
    3,896
    Thanks
    369
    Thanked 453 Times in 242 Posts
    Where did you get it from?
    I have more phones than sense - The PseudoCollection on Flickr

  5. Remove Advertisements
    NokiaUsers.net
    Advertisements
     

  6. #4

    Join Date
    Jan 2007
    Posts
    349
    Thanks
    0
    Thanked 3 Times in 3 Posts
    return it, this is a serious problem!

  7. #5
    Nokia Genius
    Join Date
    Apr 2007
    Location
    Sydney AUS
    Posts
    596
    Thanks
    6
    Thanked 30 Times in 23 Posts
    If its still 14(?) days old then return it for a new one.

    Otherwise go to your lcoal nokia site and look for your nearest nokia repair center and get them to fix it under warranty.

    Its probably just a loose connection to the CCD sensor, you could dismantle it and reseat it yourself, but that may void warranty.

  8. #6
    PPL
    PPL is offline

    Join Date
    May 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i have the same problem and i have updating the phone ver.11.0.026 too,but the issue remains.

  9. #7
    Newbie
    Join Date
    May 2007
    Location
    UK
    Posts
    14
    Thanks
    4
    Thanked 0 Times in 0 Posts
    That's exactly what mine did the second day I had it. After a bit of Googling I found out that a few folks were having the same issue, but one had updated the firmware and it cured his issue. I updated my firmware, nothing, but by then the weekend was here, so even though I had sent a mail to retailer, I didn't expect an answer till after the weekend.

    Saturday the camera started working again. Saturday night it was dead again. In the end, I found out that a 'less than gentle' tap with one finger a few times above the lens cover switch area would restore the camera to life*, much like a loose wire (though I doubt that's the case, but perhaps something is electrically misaligned?). The camera is a lot better in regards to how often it's working and I've only had to tap it once since then. My retailer finally replied today and wants me to send the phone back for an exchange but thought I'd post the above just in case it helps someone else. Obviously I'm not condoning bashing your N95 to bits just to get the camera working, but might be worth a try giving it a couple of firm taps.

    *The process for me goes -

    1) Open lens cover, grey screen, double icons
    2) Close lens cover, give it 2 or 3 firm taps above the lens area with one finger
    3) Open lens cover, Camera screen works as normal

  10. #8
    raz
    raz is offline
    Newbie
    Join Date
    Apr 2007
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation !

    bob0smith

    I was about to try your method when I opened the slider and the camera started working again.

    I'll probably return it to the retailer as this seems, like you've described, an issue that could come back.

    -r

  11. #9

    Join Date
    Apr 2007
    Posts
    84
    Thanks
    0
    Thanked 1 Time in 1 Post
    take it back you have a right to if you are not happy

  12. #10
    Nokia Guru salada2k's Avatar
    Join Date
    Mar 2007
    Location
    Australia
    Posts
    1,882
    Thanks
    39
    Thanked 245 Times in 122 Posts
    It's seems like a dry solder joint. If you're good with a soldering iron you could maybe have a go at fixing it! Sounds pretty daunting tho!


    Hit that Search button! No results? DONT PANIC. Put an * after your search term, and try again!

    I am anti 'Txt spk'. I support good grammar. I am part of the 'Save the Vowels' society. So, for your sanity and mine, type out your words. Thank you.

    Click 'Thanks' to give something back! It's FREE!

Similar Threads

  1. N95 dead???!!!! Help?!
    By NZtechfreak in forum Its Broke!
    Replies: 6
    Last Post: 06-18-2010, 09:34 AM
  2. How can i upload my Nokia Pics on the PC?
    By Allie in forum General 95
    Replies: 1
    Last Post: 10-28-2007, 03:51 PM
  3. Is my N95 dead? :(
    By Draconas in forum Its Broke!
    Replies: 5
    Last Post: 09-25-2007, 11:36 AM
  4. Nokia e90 pics and review from My Symbian
    By Brandon in forum Tech Talk
    Replies: 1
    Last Post: 02-16-2007, 12:14 AM
  5. Full nokia n95 box pics
    By ok3k1 in forum General 95
    Replies: 1
    Last Post: 01-26-2007, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •